aboutsummaryrefslogtreecommitdiffhomepage
path: root/setup.py
diff options
context:
space:
mode:
authorGravatar Mehrdad Afshari <mmx@google.com>2017-10-12 10:28:14 -0700
committerGravatar Mehrdad Afshari <mmx@google.com>2017-10-12 16:12:54 -0700
commit451c02b8bf512a89e122b3cf3862a9709c1a5e29 (patch)
treedb5237cfb3cda6aa3642b562ccf13c12a311c5f8 /setup.py
parentfbf8128da8ea1dd55729c957e915afedb8754f0d (diff)
Fix FreeBSD Ruby and Python build
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 4 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 5a85ed8545..bf8aea6b6f 100644
--- a/setup.py
+++ b/setup.py
@@ -40,10 +40,12 @@ ZLIB_INCLUDE = (os.path.join('third_party', 'zlib'),)
CARES_INCLUDE = (
os.path.join('third_party', 'cares'),
os.path.join('third_party', 'cares', 'cares'),)
-if 'linux' in sys.platform:
- CARES_INCLUDE += (os.path.join('third_party', 'cares', 'config_linux'),)
if 'darwin' in sys.platform:
CARES_INCLUDE += (os.path.join('third_party', 'cares', 'config_darwin'),)
+if 'freebsd' in sys.platform:
+ CARES_INCLUDE += (os.path.join('third_party', 'cares', 'config_freebsd'),)
+if 'linux' in sys.platform:
+ CARES_INCLUDE += (os.path.join('third_party', 'cares', 'config_linux'),)
if 'openbsd' in sys.platform:
CARES_INCLUDE += (os.path.join('third_party', 'cares', 'config_openbsd'),)
README = os.path.join(PYTHON_STEM, 'README.rst')