aboutsummaryrefslogtreecommitdiffhomepage
path: root/setup.py
diff options
context:
space:
mode:
authorGravatar Frank Groeneveld <frank@ivaldi.nl>2017-10-12 08:27:14 +0200
committerGravatar Mehrdad Afshari <mmx@google.com>2017-10-12 13:50:38 -0700
commitfbf8128da8ea1dd55729c957e915afedb8754f0d (patch)
treeea210d23f7147f849e6d807a2c827006ba549bea /setup.py
parent1ddeeb9b9e7385d85642c7f9ac3f50a6ddcef910 (diff)
Add OpenBSD support
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 90c9316b0d..5a85ed8545 100644
--- a/setup.py
+++ b/setup.py
@@ -44,6 +44,8 @@ if 'linux' in sys.platform:
CARES_INCLUDE += (os.path.join('third_party', 'cares', 'config_linux'),)
if 'darwin' in sys.platform:
CARES_INCLUDE += (os.path.join('third_party', 'cares', 'config_darwin'),)
+if 'openbsd' in sys.platform:
+ CARES_INCLUDE += (os.path.join('third_party', 'cares', 'config_openbsd'),)
README = os.path.join(PYTHON_STEM, 'README.rst')
# Ensure we're in the proper directory whether or not we're being used by pip.