aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorGravatar Joey Hess <joey@kitenet.net>2013-02-27 02:39:22 -0400
committerGravatar Joey Hess <joey@kitenet.net>2013-02-27 02:39:22 -0400
commita06989c1aeaf6463e554131993c5cb395d3f08bd (patch)
treea180b379cce80e8d4fa94cd4a15b5052316fddec /debian/rules
parent8ba6b0d9bc54656eb0d8d45adf94561f6350e792 (diff)
Makefile now builds using cabal, taking advantage of cabal's automatic detection of appropriate build flags.
The only thing lost is ./ghci Speed: make fast used to take 20 seconds here, when rebuilding from touching Command/Unused.hs. With cabal, it's 29 seconds.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules13
1 files changed, 0 insertions, 13 deletions
diff --git a/debian/rules b/debian/rules
index 8b68a8cf8..7a1b08879 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,21 +1,8 @@
#!/usr/bin/make -f
-ifeq (install ok installed,$(shell dpkg-query -W -f '$${Status}' libghc-yesod-dev 2>/dev/null))
-export FEATURES=-DWITH_ASSISTANT -DWITH_S3 -DWITH_HOST -DWITH_PAIRING -DWITH_XMPP -DWITH_OLD_HTTP_CONDUIT -DWITH_WEBAPP -DWITH_OLD_YESOD
-else
-export FEATURES=-DWITH_ASSISTANT -DWITH_S3 -DWITH_HOST -DWITH_PAIRING -DWITH_XMPP -DWITH_OLD_HTTP_CONDUIT
-endif
-ifeq (install ok installed,$(shell dpkg-query -W -f '$${Status}' libghc-dav-dev 2>/dev/null))
-export FEATURES:=${FEATURES} -DWITH_WEBDAV
-endif
-
%:
dh $@
-# Builds standalone tarball with the same FEATURES as debian package.
-standalone:
- $(MAKE) linuxstandalone
-
# Not intended for use by anyone except the author.
announcedir:
@echo ${HOME}/src/git-annex/doc/news