aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorGravatar Joey Hess <joeyh@joeyh.name>2016-01-26 15:39:37 -0400
committerGravatar Joey Hess <joeyh@joeyh.name>2016-01-26 15:39:37 -0400
commit55deaf50bbbff78360fc811d0318727840bde2bf (patch)
tree449caedaf278bf15118a3fd6a587d354084a915e /debian/rules
parent00c522c6001227e25c1ffaab866326e679359826 (diff)
Debian: Avoid building debug package, since gdb is not often useful to debug haskell programs.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules4
1 files changed, 4 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index e6ee59241..7523e2f83 100755
--- a/debian/rules
+++ b/debian/rules
@@ -25,6 +25,10 @@ override_dh_auto_install:
override_dh_fixperms:
dh_fixperms -Xld-linux
+# gdb can't do much with a haskell program, so avoid the debug package
+override_dh_strip:
+ dh_strip --no-ddebs
+
# Do not add "ldconfig" trigger since all libraries in the standalone build
# are private copies and the trigger activate-noawait trigger may not work
# on elderly distributions (e.g. squeeze)