aboutsummaryrefslogtreecommitdiff
path: root/debian/cabal-wrapper
diff options
context:
space:
mode:
authorGravatar Joey Hess <joey@kitenet.net>2014-09-26 15:08:41 -0400
committerGravatar Joey Hess <joey@kitenet.net>2014-09-26 15:08:41 -0400
commit0bf6d84f384154874820d5e2799f6f71edb0fc28 (patch)
treeb5d0313fc326638754f8cf48284e31baf63b6833 /debian/cabal-wrapper
parent6d4ba2f84b90222c8cfda0fbc435beb51d3849c3 (diff)
Work around failure to build on mips by using cabal, not Setup, to build in debian/rules.
Diffstat (limited to 'debian/cabal-wrapper')
-rwxr-xr-xdebian/cabal-wrapper16
1 files changed, 16 insertions, 0 deletions
diff --git a/debian/cabal-wrapper b/debian/cabal-wrapper
new file mode 100755
index 000000000..e0623f79f
--- /dev/null
+++ b/debian/cabal-wrapper
@@ -0,0 +1,16 @@
+#!/bin/sh
+# It would be more usual to use:
+# export CABAL=./Setup
+# But Setup currently has a very bad dependency resolver, and very bad
+# debugging output, and tends to eat all memory and die on small buildds.
+#
+# This should be revisited once Debian has a newer ghc than 7.6.3,
+# and hopefully gets the improved dependency resolver from cabal.
+set -e
+
+# Avoid cabal writing to HOME, and avoid local cabal settings
+# influencing the build.
+HOME=$(mktemp -d)
+export HOME
+
+cabal "$@"