aboutsummaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac34
1 files changed, 1 insertions, 33 deletions
diff --git a/configure.ac b/configure.ac
index 85c9fed4..bf3defcf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -34,7 +34,6 @@ AC_SUBST(LIBS_SET_COLOR)
AC_SUBST(localedir)
AC_SUBST(optbindirs)
AC_SUBST(prefix)
-AC_SUBST(SEQ_FALLBACK)
AC_SUBST(XSEL)
AC_SUBST(XSEL_MAN)
AC_SUBST(XSEL_BIN)
@@ -168,37 +167,6 @@ AC_PROG_CPP
AC_PROG_INSTALL
#
-# Check for seq command. If missing, make sure fallback shellscript
-# implementation is installed.
-#
-
-AC_CHECK_PROG( SEQ_FALLBACK, seq, [ ], [seq])
-
-
-if test "$SEQ_FALLBACK"; then
-
- #
- # We already have seq. Check if the seq version is installed by an
- # earlier fish version. If it is, we'll replace it.
- #
-
- file=`which seq`
- if test -f "$file"; then
-
- AC_MSG_CHECKING([if seq comes from a previous fish version])
- shebang=`grep "\(^#!/.*/fish\|^#!/usr/bin/env fish\)" $file`
-
- if test "$shebang"; then
- SEQ_FALLBACK=seq
- AC_MSG_RESULT(yes, replace it)
- else
- AC_MSG_RESULT(no, keep it)
- fi
- fi
-fi
-
-
-#
# Optionally drop xsel command
#
@@ -950,7 +918,7 @@ case $target_os in
esac
# Tell the world what we know
-AC_CONFIG_FILES([Makefile fish.spec seq])
+AC_CONFIG_FILES([Makefile fish.spec])
AC_OUTPUT
if test ! x$local_found_posix_switch = xyes; then