aboutsummaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar ridiculousfish <corydoras@ridiculousfish.com>2013-01-12 15:18:19 -0800
committerGravatar ridiculousfish <corydoras@ridiculousfish.com>2013-01-12 15:18:19 -0800
commite1190eb1f34418f6c7a422f537eb75a434e71240 (patch)
treef7476c86ab0d6ccac5aece392ed4e4fd573e0860 /configure.ac
parentdc37a8079e4b1a69300a4bf1bdd00f8e2c66e1d5 (diff)
Remove seq.in, in favor of the new function. Remove seq detection from configure.ac. Teach the Makefile how to remove old installed seqs.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac34
1 files changed, 1 insertions, 33 deletions
diff --git a/configure.ac b/configure.ac
index 85c9fed4..bf3defcf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -34,7 +34,6 @@ AC_SUBST(LIBS_SET_COLOR)
AC_SUBST(localedir)
AC_SUBST(optbindirs)
AC_SUBST(prefix)
-AC_SUBST(SEQ_FALLBACK)
AC_SUBST(XSEL)
AC_SUBST(XSEL_MAN)
AC_SUBST(XSEL_BIN)
@@ -168,37 +167,6 @@ AC_PROG_CPP
AC_PROG_INSTALL
#
-# Check for seq command. If missing, make sure fallback shellscript
-# implementation is installed.
-#
-
-AC_CHECK_PROG( SEQ_FALLBACK, seq, [ ], [seq])
-
-
-if test "$SEQ_FALLBACK"; then
-
- #
- # We already have seq. Check if the seq version is installed by an
- # earlier fish version. If it is, we'll replace it.
- #
-
- file=`which seq`
- if test -f "$file"; then
-
- AC_MSG_CHECKING([if seq comes from a previous fish version])
- shebang=`grep "\(^#!/.*/fish\|^#!/usr/bin/env fish\)" $file`
-
- if test "$shebang"; then
- SEQ_FALLBACK=seq
- AC_MSG_RESULT(yes, replace it)
- else
- AC_MSG_RESULT(no, keep it)
- fi
- fi
-fi
-
-
-#
# Optionally drop xsel command
#
@@ -950,7 +918,7 @@ case $target_os in
esac
# Tell the world what we know
-AC_CONFIG_FILES([Makefile fish.spec seq])
+AC_CONFIG_FILES([Makefile fish.spec])
AC_OUTPUT
if test ! x$local_found_posix_switch = xyes; then