aboutsummaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 11 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 3552c5c3..34f25e1f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -86,6 +86,17 @@ else
AC_MSG_RESULT([no])
fi
+#
+# Set up various programs needed for install
+# Note AC_PROG_CXX sets CXXFLAGS if not set, which we want
+# So ensure this happens before we modify CXXFLAGS below
+#
+
+AC_PROG_CXX([g++ c++])
+AC_PROG_CPP
+AC_PROG_INSTALL
+
+echo "CXXFLAGS: $CXXFLAGS"
#
# Detect directories which may contain additional headers, libraries
@@ -148,15 +159,6 @@ AH_BOTTOM([#if __GNUC__ >= 3
#
-# Set up various programs needed for install
-#
-
-AC_PROG_CXX([g++ c++])
-AC_PROG_CPP
-AC_PROG_INSTALL
-
-
-#
# Optionally drop gettext support
#