aboutsummaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 12 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 52bc00f1..f9b44661 100644
--- a/configure.ac
+++ b/configure.ac
@@ -24,6 +24,7 @@ conf_arg=$@
AC_SUBST(HAVE_GETTEXT)
AC_SUBST(HAVE_DOXYGEN)
AC_SUBST(LDFLAGS_FISH)
+AC_SUBST(WCHAR_T_BITS)
#
@@ -375,17 +376,16 @@ if test x$local_gettext != xno; then
AC_CHECK_HEADERS([libintl.h])
fi
-AC_CHECK_HEADER(
- [regex.h],
- [
- AC_DEFINE(
- [HAVE_REGEX_H],
- [1],
- [Define to 1 if you have the <regex.h> header file.]
- )
- ],
- [AC_MSG_ERROR([Could not find the header regex.h, needed to build fish])]
-)
+
+#
+# Get the size in bits of wchar_t, needed for configuring the pcre2 build
+# and for code that #includes pcre2.h
+#
+
+AC_CHECK_SIZEOF(wchar_t)
+WCHAR_T_BITS=`expr 8 \* $ac_cv_sizeof_wchar_t`
+AC_DEFINE_UNQUOTED([WCHAR_T_BITS], [$WCHAR_T_BITS], [The size of wchar_t in bits.])
+
#
# On some platforms (Solaris 10) adding -std=c99 in turn requires that
@@ -785,6 +785,7 @@ else
AC_MSG_RESULT(no)
fi
+
# Check for Solaris curses tputs having fixed length parameter list.
AC_MSG_CHECKING([if we are using non varargs tparm.])
AC_COMPILE_IFELSE(