aboutsummaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 4 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 205d1bfe..16efd236 100644
--- a/configure.ac
+++ b/configure.ac
@@ -230,12 +230,11 @@ AC_SUBST( DATADIR, ["$(eval echo $datadir)"] )
AC_ARG_VAR( [docdir], [Documentation direcotry] )
if test -z $docdir; then
- AC_SUBST(docdir,[$datadir/doc/fish])
+ AC_SUBST(docdir, [$datadir/doc/fish] )
+else
+ AC_SUBST(docdir, [$docdir])
fi
-AC_DEFINE_UNQUOTED( DOCDIR, [L"$(eval echo $docdir)"], [Documentation directory] )
-
-
# Set up locale directory. This is where the .po files will be
# installed.
AC_DEFINE_UNQUOTED( [LOCALEDIR], "$(eval echo $datadir)/locale", [Locale directory])
@@ -348,7 +347,7 @@ case $target_os in
esac
# Tell the world what we know
-AC_CONFIG_FILES([Makefile fish.spec doc_src/fish.1 doc_src/Doxyfile etc/fish etc/fish_interactive.fish share/fish seq])
+AC_CONFIG_FILES([Makefile fish.spec doc_src/fish.1 doc_src/Doxyfile etc/fish_interactive.fish seq])
AC_OUTPUT
echo "fish is now configured."