aboutsummaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar David Adam <zanchey@ucc.gu.uwa.edu.au>2016-05-06 23:55:07 +0100
committerGravatar David Adam <zanchey@ucc.gu.uwa.edu.au>2016-05-18 22:39:20 +0000
commite39628bbe934a895ec6accac2446919ff8f13563 (patch)
treea24ce6280ef37b6d8dcadbdc48d86319853d8d17 /configure.ac
parentf5dcb6a0cbe504e63f30d45627eb0ab5f617747f (diff)
configure: drop unnecessary feature flag checks
Work on #2999.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac43
1 files changed, 0 insertions, 43 deletions
diff --git a/configure.ac b/configure.ac
index 3b3c2ef8..05ed5b96 100644
--- a/configure.ac
+++ b/configure.ac
@@ -231,49 +231,6 @@ LDFLAGS="$prev_LDFLAGS"
#
-# If we are compiling against glibc, set some flags to work around
-# some rather stupid attempts to hide prototypes for *wprintf
-# functions, as well as prototypes of various gnu extensions.
-#
-
-AC_MSG_CHECKING([if we are compiling against glibc])
-AC_RUN_IFELSE(
- [
- AC_LANG_PROGRAM(
- [
- #include <stdlib.h>
- #ifdef __GLIBC__
- #define STATUS 0
- #else
- #define STATUS 1
- #endif
- ],
- [
- return STATUS;
- ]
- )
- ],
- [glibc=yes],
- [glibc=no]
-)
-
-if test "$glibc" = yes; then
- AC_MSG_RESULT(yes)
-
- #
- # This gives us access to prototypes for gnu extensions and C99
- # functions if we are compiling agains glibc. All GNU extensions
- # that are used must have a fallback implementation available in
- # fallback.h, in order to keep fish working on non-gnu platforms.
- #
-
- CXXFLAGS="$CXXFLAGS -D_GNU_SOURCE=1 -D_ISO99_SOURCE=1"
-else
- AC_MSG_RESULT(no)
-fi
-
-
-#
# Test cpu for special handling of ppc
#
# This is used to skip use of tputs on ppc systems, since it seemed to