aboutsummaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar David Adam (zanchey) <zanchey@ucc.gu.uwa.edu.au>2013-02-24 23:00:54 +0800
committerGravatar ridiculousfish <corydoras@ridiculousfish.com>2013-03-05 12:25:00 -0800
commitdaf5ef1bbd4b8ceb005294c512004010010897b8 (patch)
tree8c87ace4aa251b100a2aa4d1aea103481bf269d4 /configure.ac
parent85a5319c4b789dc1682d0fd10891e488c923791e (diff)
Kill termio.h and sys/termios.h
On FreeBSD, compilation complains that "this file includes <sys/termios.h> which is deprecated, use <termios.h> instead". On Linux and FreeBSD, <sys/termios.h> literally just pulls in <termios.h>. On OS X and Solaris, <termios.h> pulls in <sys/termios.h>. <termio.h> doesn't exist on FreeBSD or Mac OS X, and on Linux is marked as deprecated and just includes <termios.h>. It does exist on Solaris, but no `struct termio` is ever actually used in the codebase.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 3 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index c94fa5a6..f5a54837 100644
--- a/configure.ac
+++ b/configure.ac
@@ -537,7 +537,7 @@ LIBS=$LIBS_COMMON
# Check presense of various header files
#
-AC_CHECK_HEADERS([getopt.h termio.h sys/resource.h term.h ncurses/term.h ncurses.h curses.h stropts.h siginfo.h sys/select.h sys/ioctl.h sys/termios.h execinfo.h spawn.h])
+AC_CHECK_HEADERS([getopt.h termios.h sys/resource.h term.h ncurses/term.h ncurses.h curses.h stropts.h siginfo.h sys/select.h sys/ioctl.h execinfo.h spawn.h])
if test x$local_gettext != xno; then
AC_CHECK_HEADERS([libintl.h])
@@ -620,13 +620,6 @@ for i in "" "-D_POSIX_C_SOURCE=200112L" "-D_XOPEN_SOURCE=600 -D_POSIX_C_SOURCE=2
#include <siginfo.h>
#endif
- #ifdef HAVE_SYS_TERMIOS_H
- /* Neither POSIX, C89 nor C99: a common extension.
- * For: TIOCGWINSZ and struct winsize (under at least
- * Solaris, NetBSD and (dual-listed) FreeBSD). */
- #include <sys/termios.h>
- #endif
-
#ifdef HAVE_SYS_IOCTL_H
/* As above (under at least Linux and FreeBSD). */
#include <sys/ioctl.h>
@@ -750,8 +743,8 @@ AC_LINK_IFELSE(
[
AC_LANG_PROGRAM(
[
- #ifdef HAVE_SYS_TERMIOS_H
- #include <sys/termios.h>
+ #ifdef HAVE_TERMIOS_H
+ #include <termios.h>
#endif
#ifdef HAVE_SYS_IOCTL_H