aboutsummaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar axel <axel@liljencrantz.se>2006-05-20 01:14:43 +1000
committerGravatar axel <axel@liljencrantz.se>2006-05-20 01:14:43 +1000
commitbbf2a3836fa10b9539a5d8d0bbd143349f2c67e4 (patch)
tree9f5a5713b99859d014834aebd384cd2fed848bc0 /configure.ac
parent1aa1ab540ea1706772dfcea34ca2980d954eae42 (diff)
Simplify code for detecting which macros are defined in sys/resource.h, no configure-time tests are needed
darcs-hash:20060519151443-ac50b-c87dba2175f5bf8d652c783559c3a9992247aa01.gz
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac47
1 files changed, 0 insertions, 47 deletions
diff --git a/configure.ac b/configure.ac
index 9d2f103d..4d3c7803 100644
--- a/configure.ac
+++ b/configure.ac
@@ -326,53 +326,6 @@ if test "$ac_cv_func_fwprintf" = yes; then
fi
-# Check for RLIMIT_NPROC in sys/resource.h.
-AC_MSG_CHECKING([for RLIMIT_NPROC in sys/resource.h])
-AC_TRY_COMPILE([#include <sys/resource.h>],
-[int tmp; tmp=RLIMIT_NPROC;], have_rlimit_as=yes, have_rlimit_as=no)
-if test "$have_rlimit_as" = yes; then
- AC_MSG_RESULT(yes)
- AC_DEFINE([HAVE_RLIMIT_NPROC], [1],
- [Define to 1 if HAVE_RLIMIT_NPROC is defined in <sys/resource.h>.])
-else
- AC_MSG_RESULT(no)
-fi
-
-# Check for RLIMIT_AS in sys/resource.h.
-AC_MSG_CHECKING([for RLIMIT_AS in sys/resource.h])
-AC_TRY_COMPILE([#include <sys/resource.h>],
-[int tmp; tmp=RLIMIT_AS;], have_rlimit_as=yes, have_rlimit_as=no)
-if test "$have_rlimit_as" = yes; then
- AC_MSG_RESULT(yes)
- AC_DEFINE([HAVE_RLIMIT_AS], [1],
- [Define to 1 if HAVE_RLIMIT_AS is defined in <sys/resource.h>.])
-else
- AC_MSG_RESULT(no)
-fi
-
-# Check for RLIMIT_MEMLOCK in sys/resource.h.
-AC_MSG_CHECKING([for RLIMIT_MEMLOCK in sys/resource.h])
-AC_TRY_COMPILE([#include <sys/resource.h>],
-[int tmp; tmp=RLIMIT_MEMLOCK;], have_rlimit_as=yes, have_rlimit_as=no)
-if test "$have_rlimit_as" = yes; then
- AC_MSG_RESULT(yes)
- AC_DEFINE([HAVE_RLIMIT_MEMLOCK], [1],
- [Define to 1 if HAVE_RLIMIT_MEMLOCK is defined in <sys/resource.h>.])
-else
- AC_MSG_RESULT(no)
-fi
-
-# Check for RLIMIT_RSS in sys/resource.h.
-AC_MSG_CHECKING([for RLIMIT_RSS in sys/resource.h])
-AC_TRY_COMPILE([#include <sys/resource.h>],
-[int tmp; tmp=RLIMIT_RSS;], have_rlimit_as=yes, have_rlimit_as=no)
-if test "$have_rlimit_as" = yes; then
- AC_MSG_RESULT(yes)
- AC_DEFINE([HAVE_RLIMIT_RSS], [1],
- [Define to 1 if HAVE_RLIMIT_RSS is defined in <sys/resource.h>.])
-else
- AC_MSG_RESULT(no)
-fi
# Check for _nl_msg_cat_cntr symbol
AC_MSG_CHECKING([for _nl_msg_cat_cntr symbol])