aboutsummaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar axel <axel@liljencrantz.se>2007-02-05 22:25:53 +1000
committerGravatar axel <axel@liljencrantz.se>2007-02-05 22:25:53 +1000
commitabff4e5b412348ccf7bf176ef699e45bc98abe19 (patch)
tree4d4254190a9c7adc39c74a6e44e30c398dd2d27c /configure.ac
parent25082b65287dff0c0f0023677b068ac231fdb008 (diff)
Add flags for long file support in configure.ac. They should be useful when supported (e.g. Linux and Solaris) and should do no harm when unsupported.
darcs-hash:20070205122553-ac50b-93adeeafc5c4bb43397e4b088f6e9de5744b3058.gz
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 76ef63c4..248ce04e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -245,6 +245,14 @@ AC_CACHE_VAL(
]
)
+#
+# Try to enale large file support. This will make sure that on systems
+# where off_t can be either 32 or 64 bit, the latter size is used. On
+# other systems, this should do nothing. (Hopefully)
+#
+
+CFLAGS="$CFLAGS -D_LARGEFILE_SOURCE=1 -D_FILE_OFFSET_BITS=64"
+
AC_MSG_RESULT($local_cv_has__std_c99)
case x$local_cv_has__std_c99 in
xno)