aboutsummaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar ridiculousfish <corydoras@ridiculousfish.com>2012-01-06 10:43:27 -0800
committerGravatar ridiculousfish <corydoras@ridiculousfish.com>2012-01-06 10:43:27 -0800
commit9ef9284a34aaf350392856481515c71a4421b8a6 (patch)
tree02cb27f7d9bb6c88141614a739041eb2751b840b /configure.ac
parent820acb981bdeb888efa7e5dc7e432de9f8df5598 (diff)
Fix for bogus cast warning in configure script that was breaking local_cv_use__posix_c_source
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 1863304c..3391a852 100644
--- a/configure.ac
+++ b/configure.ac
@@ -650,19 +650,19 @@ for i in "" "-D_POSIX_C_SOURCE=200112L" "-D_XOPEN_SOURCE=600 -D_POSIX_C_SOURCE=2
[
/* Avert high-level optimisation, by making the program's
* return value depend on all tested identifiers. */
- int ret = 0;
+ long ret = 0;
/* POSIX only: might be unhidden by _POSIX_C_SOURCE. */
struct sigaction sa;
sigset_t ss;
siginfo_t info;
- ret += (int)(void *)&info + kill( 0, 0 ) +
+ ret += (long)(void *)&info + kill( 0, 0 ) +
sigaction( 0, &sa, 0 ) + sigemptyset( &ss );
/* Extended-POSIX: might be unhidden by _XOPEN_SOURCE. */
ret += killpg( 0, 0 );
/* Non-standard: might be hidden by the macros. */
{
struct winsize termsize;
- ret += (int)(void *)&termsize;
+ ret += (long)(void *)&termsize;
ret += SIGWINCH + TIOCGWINSZ + SIGIO;
}
return ret;