aboutsummaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Carl Johan Crafoord <mail@carljohancrafoord.se>2012-06-06 15:57:52 +0200
committerGravatar ridiculousfish <corydoras@ridiculousfish.com>2012-06-10 00:33:01 -0700
commit96a4b7eaa76a44cf17f8d52af985801e1b11fb9a (patch)
tree354b3d32c907348a664feb26c436d0e3fcc331a2 /configure.ac
parent64afada7f0d23aa5f5ab2f0c455cf3a06f5d9836 (diff)
Check for libiconv_open if we can't find iconv_open
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index f132e410..111178eb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -512,7 +512,7 @@ LIBS="$LIBS_SHARED"
if test x$local_gettext != xno; then
AC_SEARCH_LIBS( gettext, intl,,)
fi
-AC_SEARCH_LIBS( iconv_open, iconv, , [AC_MSG_ERROR([Could not find an iconv implementation, needed to build fish])] )
+AC_SEARCH_LIBS( iconv_open, iconv, , [AC_SEARCH_LIBS( libiconv_open, iconv, , [AC_MSG_ERROR([Could not find an iconv implementation, needed to build fish])] )] )
LIBS_FISH_PAGER=$LIBS
LIBS=$LIBS_COMMON
@@ -525,7 +525,7 @@ LIBS="$LIBS_SHARED"
if test x$local_gettext != xno; then
AC_SEARCH_LIBS( gettext, intl,,)
fi
-AC_SEARCH_LIBS( iconv_open, iconv, , [AC_MSG_ERROR([Could not find an iconv implementation, needed to build fish])] )
+AC_SEARCH_LIBS( iconv_open, iconv, , [AC_SEARCH_LIBS( libiconv_open, iconv, , [AC_MSG_ERROR([Could not find an iconv implementation, needed to build fish])] )] )
LIBS_FISHD=$LIBS
LIBS=$LIBS_COMMON