aboutsummaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar axel <axel@liljencrantz.se>2006-08-11 06:37:56 +1000
committerGravatar axel <axel@liljencrantz.se>2006-08-11 06:37:56 +1000
commit8da54a1955d590c79f0f4afc4c42374ebc213b05 (patch)
treea749a31bbe816bc841ea0ac38c8816575cf17f03 /configure.ac
parent6899e4e734a5693fb9168eb8837780dd45775a25 (diff)
Add two BSD-specific preprocessor macros to get additional prototypes. Thanks to Netocrat.
darcs-hash:20060810203756-ac50b-21259e610fc738c6ad990d88b0af74d56d6a38f8.gz
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4678be77..e42adf9f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -208,6 +208,7 @@ if test $target_cpu = powerpc; then
AC_DEFINE([TPUTS_KLUDGE],[1],[Evil kludge to get Power based machines to work])
fi
+# Solaris-specific flags go here
AC_MSG_CHECKING([if we are under Solaris])
case $target_os in
solaris*)
@@ -220,6 +221,20 @@ case $target_os in
esac
+# BSD-specific flags go here
+AC_MSG_CHECKING([if we are under BSD])
+case $target_os in
+ *bsd*)
+ AC_DEFINE( __BSD_VISIBLE, 1, [Macro to enable additional prototypes under BSD])
+ AC_DEFINE( _NETBSD_SOURCE, 1, [Macro to enable additional prototypes under BSD])
+ AC_MSG_RESULT(yes)
+ ;;
+ *)
+ AC_MSG_RESULT(no)
+ ;;
+esac
+
+
# Set up PREFIX and related preprocessor symbols. Fish needs to know
# where it will be installed. One of the reasons for this is so that
# it can make sure the fish installation directory is in the path