aboutsummaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar axel <axel@liljencrantz.se>2006-08-11 23:48:59 +1000
committerGravatar axel <axel@liljencrantz.se>2006-08-11 23:48:59 +1000
commit8b395d05ef6d31512cac9b2927102e3a97881cb9 (patch)
tree0f904ea109fb62a3a6d742112d6d1391ea614ef6 /configure.ac
parent8392902cec6dc7801a98ae8ebd5c0dffaeb84073 (diff)
Switch to using AC_DEFINE instead of using -D switces in CFLAGS for a few macros that don't need to be passed through the Makefile
darcs-hash:20060811134859-ac50b-6efc59b9214909aa6804bed9c5919ed0e29ddf81.gz
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 8 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 51a7beec..35c52463 100644
--- a/configure.ac
+++ b/configure.ac
@@ -72,7 +72,9 @@ for i in /usr/pkg /sw /opt /opt/local; do
done
-CFLAGS="$CFLAGS -D_XOPEN_SOURCE=600 -D_POSIX_C_SOURCE=200112L"
+# These help out with getting better prototypes on some platforms
+AC_DEFINE( _XOPEN_SOURCE, 600, [Macro to enable additional prototypes under Posix] )
+AC_DEFINE( _POSIX_C_SOURCE, 200112L, [Macro to enable additional prototypes under Posix] )
AC_SUBST( optbindirs, $optbindirs )
@@ -187,8 +189,8 @@ if test "$glibc" = yes; then
# fallback.h, in order to keep fish working on non-gnu platforms.
#
- CFLAGS="$CFLAGS -D _GNU_SOURCE -D _ISOC99_SOURCE"
-
+ AC_DEFINE( _GNU_SOURCE, 1, [Macro to enable additional prototypes under Glibc])
+ AC_DEFINE( _ISOC99_SOURCE, 1, [Macro to enable additional prototypes under Glibc])
else
AC_MSG_RESULT(no)
fi
@@ -211,8 +213,8 @@ fi
# Solaris-specific flags go here
AC_MSG_CHECKING([if we are under Solaris])
case $target_os in
- solaris*)
- CFLAGS="$CFLAGS -D__EXTENSIONS__=1"
+ solaris*)
+ AC_DEFINE( __EXTENSIONS__, 1, [Macro to enable additional prototypes under Solaris])
AC_MSG_RESULT(yes)
;;
*)
@@ -224,7 +226,7 @@ esac
# BSD-specific flags go here
AC_MSG_CHECKING([if we are under BSD])
case $target_os in
- *bsd*)
+ *bsd*)
AC_DEFINE( __BSD_VISIBLE, 1, [Macro to enable additional prototypes under BSD])
AC_DEFINE( _NETBSD_SOURCE, 1, [Macro to enable additional prototypes under BSD])
AC_MSG_RESULT(yes)