aboutsummaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar lledey <lledey@gmail.com>2012-12-12 01:14:49 +0100
committerGravatar ridiculousfish <corydoras@ridiculousfish.com>2012-12-12 13:23:16 -0800
commit82223d3badd16ec3188294345196975600b73e6d (patch)
tree1917f9cf68f0b69f3f798cd92b52c944fdfb1710 /configure.ac
parent56dd25667d1739a51a3946de060dd44e2994c39b (diff)
Remove -rdynamic compilation flag for OSX
This flag is used for the backtrace() function. It provides more information for the backtrace on Linux, but is useless on OSX. Signed-off-by: lledey <lledey@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index e413be09..db437ff3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -275,10 +275,12 @@ if test "$GCC" = yes; then
CXXFLAGS="$CXXFLAGS -Wall"
#
- # This is needed in order to get the really cool backtraces
+ # This is needed in order to get the really cool backtraces on Linux
#
- LDFLAGS_FISH="$LDFLAGS_FISH -rdynamic"
+ if test `uname` != "Darwin"; then
+ LDFLAGS_FISH="$LDFLAGS_FISH -rdynamic"
+ fi
fi