aboutsummaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Konrad Borowski <x.fix@o2.pl>2014-05-01 11:00:13 +0200
committerGravatar Konrad Borowski <x.fix@o2.pl>2014-05-01 11:00:13 +0200
commit77bc4c572525c96b43f70c4f1e0c6ef250933713 (patch)
tree5ebd1406720d8fda9c59d8fbffa1cd8e1962f2b7 /configure.ac
parentdd47da92f55eca39b938174b246711f1cb6b0e65 (diff)
Properly check for miliseconds during screen update
This removes undefined behavior in the previous code by properly checking for miliseconds (actually typing proper names, not abusing pointer arithmetics).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 150591af..1b91f962 100644
--- a/configure.ac
+++ b/configure.ac
@@ -396,6 +396,11 @@ AC_CHECK_HEADER(
[AC_MSG_ERROR([Could not find the header regex.h, needed to build fish])]
)
+#
+# Detect nanoseconds fields in struct stat
+#
+AC_CHECK_MEMBERS([struct stat.st_mtimespec.tv_nsec])
+AC_CHECK_MEMBERS([struct stat.st_mtim.tv_nsec])
#
# On some platforms (Solaris 10) adding -std=c99 in turn requires that