aboutsummaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar ridiculousfish <corydoras@ridiculousfish.com>2012-01-06 11:50:17 -0800
committerGravatar ridiculousfish <corydoras@ridiculousfish.com>2012-01-06 11:50:17 -0800
commit76f870a30a5b7f2f6c2ad91fa96af995e0f78899 (patch)
tree0e0d215ce48610c7083124808c6a76bc826657dd /configure.ac
parent02092f315e8ab7956395491fb8e2fe2235f2bd17 (diff)
Improved check for pthread library to build successfully on Linux
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4c06ee72..f132e410 100644
--- a/configure.ac
+++ b/configure.ac
@@ -468,6 +468,7 @@ LIBS_COMMON=$LIBS
LIBS=""
AC_SEARCH_LIBS( connect, socket, , [AC_MSG_ERROR([Cannot find the socket library, needed to build this package.] )] )
AC_SEARCH_LIBS( nanosleep, rt, , [AC_MSG_ERROR([Cannot find the rt library, needed to build this package.] )] )
+AC_SEARCH_LIBS( pthread_create, pthread, , [AC_MSG_ERROR([Cannot find the pthread library, needed to build this package.] )] )
AC_SEARCH_LIBS( setupterm, [ncurses curses], , [AC_MSG_ERROR([Could not find a curses implementation, needed to build fish])] )
AC_SEARCH_LIBS( [nan], [m], [AC_DEFINE( [HAVE_NAN], [1], [Define to 1 if you have the nan function])] )
LIBS_SHARED=$LIBS