aboutsummaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar David Adam <zanchey@ucc.gu.uwa.edu.au>2015-07-29 21:13:38 +0800
committerGravatar David Adam <zanchey@ucc.gu.uwa.edu.au>2015-07-29 21:13:40 +0800
commit75515af53754cb152d7fa9c63547f788946ec37b (patch)
treef0c495f0681c64985a7b4244b9f2b1fb360525d0 /configure.ac
parentb1ed15a07ae02184c4cd952ed10ba925f30e346d (diff)
configure: only define special attributes if not defined
Fixes a build warning on FreeBSD, where <sys/cdefs.h> defines __packed and friends.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 77a9e5f3..52bc00f1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -107,9 +107,15 @@ AC_CONFIG_HEADERS(config.h)
#
AH_BOTTOM([#if __GNUC__ >= 3
+#ifndef __warn_unused
#define __warn_unused __attribute__ ((warn_unused_result))
+#endif
+#ifndef __sentinel
#define __sentinel __attribute__ ((sentinel))
+#endif
+#ifndef __packed
#define __packed __attribute__ ((packed))
+#endif
#else
#define __warn_unused
#define __sentinel