aboutsummaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar axel <axel@liljencrantz.se>2009-02-23 05:16:49 +1000
committerGravatar axel <axel@liljencrantz.se>2009-02-23 05:16:49 +1000
commit6dbb9e070d5332ac99d881a07346e5e8fba1bb1a (patch)
treec6f6ef6e97790c823ee9841b0a33e52920793d22 /configure.ac
parent47ae2a05ceb559744ce8505acc833493af3ab72d (diff)
Hopefully make iconv detection work on OS X with non-gnu iconv implementation
darcs-hash:20090222191649-ac50b-4f7010fdbf662b71cb7c4c99d2ae6e00c7cccb83.gz
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 600e52b5..720c5dae 100644
--- a/configure.ac
+++ b/configure.ac
@@ -519,7 +519,9 @@ if test x$local_gettext != xno; then
AC_SEARCH_LIBS( gettext, intl,,)
fi
-AC_SEARCH_LIBS( iconv_open, iconv, , [AC_MSG_ERROR([Could not find an iconv implementation, needed to build fish])] )
+# Check for libiconv_open if we can't find iconv_open. Silly OS X does
+# weird macro magic for the sole purpose of amusing me.
+AC_SEARCH_LIBS( iconv_open, iconv, , [AC_SEARCH_LIBS( libiconv_open, iconv, , [AC_MSG_ERROR([Could not find an iconv implementation, needed to build fish])] )] )
LIBS_FISH=$LIBS
LIBS=$LIBS_COMMON