aboutsummaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Kurtis Rader <krader@skepticism.us>2016-03-03 15:36:17 -0800
committerGravatar Kurtis Rader <krader@skepticism.us>2016-03-08 13:38:57 -0800
commit6a16bdb808b02977cc99f84b4adae420f99019d2 (patch)
tree6fcb706091da63dc24a0e1ecff84aa86e30f0e29 /configure.ac
parent5e09411340b347caf2f81dc65fc9d3a1fefac261 (diff)
assume getopt/getopt_long is available
There is no longer a good reason to detect whether or not getopt_long() is available. All UNIX implementations we're likely to run on have it. And if we ever find one that doesn't the right thing to do is not fallback to getopt() but to include the getopt_long() source in our package like we do with the pcre2 library. Since it's licensed under LGPL we can legally do so if it becomes necessary. This partially addresses issue #2790.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac37
1 files changed, 0 insertions, 37 deletions
diff --git a/configure.ac b/configure.ac
index fe8b3a73..af4fc5af 100644
--- a/configure.ac
+++ b/configure.ac
@@ -752,43 +752,6 @@ else
AC_MSG_RESULT(no)
fi
-# Check if getopt_long exists and works
-AC_MSG_CHECKING([if getopt_long exists and works])
-AC_TRY_LINK(
- [
- #if HAVE_GETOPT_H
- #include <getopt.h>
- #endif
- ],
- [
- static struct option
- long_options[] =
- {
- 0, 0, 0, 0
- }
- ;
- int opt = getopt_long( 0,
- 0,
- 0,
- long_options,
- 0 );
-
- ],
- have_working_getopt_long=yes,
- have_working_getopt_long=no
-)
-if test "$have_working_getopt_long" = yes; then
- AC_MSG_RESULT(yes)
- AC_DEFINE(
- [HAVE_WORKING_GETOPT_LONG],
- [1],
- [Define to 1 if getopt_long exists and works.]
- )
-else
- AC_MSG_RESULT(no)
-fi
-
-
# Check for Solaris curses tputs having fixed length parameter list.
AC_MSG_CHECKING([if we are using non varargs tparm.])
AC_COMPILE_IFELSE(