aboutsummaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar axel <axel@liljencrantz.se>2006-08-01 11:30:18 +1000
committerGravatar axel <axel@liljencrantz.se>2006-08-01 11:30:18 +1000
commit696b4df1c6cb0360b77515717a3e7cbdcf74337a (patch)
tree07d1c326fd6506711a2d8a6661a54619812341e1 /configure.ac
parent65f4d6e866e0aaed2b71a4a55b83e0f84cc9adbc (diff)
Add __EXTENSIONS__ macro when under Solaris
darcs-hash:20060801013018-ac50b-08925f5e5239e48ca3024717d5fec2e82138ca5a.gz
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f957ce5a..0fdc27d3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -206,6 +206,17 @@ if test $target_cpu = powerpc; then
AC_DEFINE([TPUTS_KLUDGE],[1],[Evil kludge to get Power based machines to work])
fi
+AC_MSG_CHECKING([if we are under Solaris])
+case $target_os in
+ solaris*)
+ CFLAGS="$CFLAGS -D__EXTENSIONS__=1"
+ AC_MSG_RESULT(yes)
+ ;;
+ *)
+ AC_MSG_RESULT(no)
+ ;;
+esac
+
# Set up PREFIX and related preprocessor symbols. Fish needs to know
# where it will be installed. One of the reasons for this is so that