aboutsummaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar ridiculousfish <corydoras@ridiculousfish.com>2016-04-30 17:46:14 -0700
committerGravatar ridiculousfish <corydoras@ridiculousfish.com>2016-04-30 17:46:14 -0700
commit58d7c4b388067771e0ce1cf0dffd376c6b7fb9f2 (patch)
tree1e6f3d780cdfe1c6f5ca35bd4b2787ce907f9682 /configure.ac
parenta897ef002521a3991adc4342189f0e30a0d048b0 (diff)
Remove use of __environ
It has apparently never worked. Fixes #2988
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 0 insertions, 24 deletions
diff --git a/configure.ac b/configure.ac
index 87bf46b7..0236fc8a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -675,30 +675,6 @@ else
AC_MSG_RESULT(no)
fi
-# Check for __environ symbol
-AC_MSG_CHECKING([for __environ symbol])
-AC_TRY_LINK(
- [
- #include <unistd.h>
- ],
- [
- extern char **__environ;
- char **tmp = __environ;
- exit(tmp!=0);
- ],
- have___environ=yes,
- have___environ=no
-)
-if test "$have___environ" = yes; then
- AC_MSG_RESULT(yes)
- AC_DEFINE(
- [HAVE___ENVIRON],
- [1],
- [Define to 1 if the __environ symbol is exported.]
- )
-else
- AC_MSG_RESULT(no)
-fi
# Check for sys_errlist
AC_MSG_CHECKING([for sys_errlist array])