aboutsummaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar axel <axel@liljencrantz.se>2006-05-11 21:58:46 +1000
committerGravatar axel <axel@liljencrantz.se>2006-05-11 21:58:46 +1000
commit524e0aa174224641bc6807ec112e46f98e27cfe0 (patch)
treead2aaf26c7a687ff6a3bec16d47c7fc2e650588f /configure.ac
parent94abb30f94a3ea9279d25dbc83989e9a0c454ab2 (diff)
Add fallback del_curterm which does nothing, used in preference to BSD curses del_curterm, which seems to do a double-free
darcs-hash:20060511115846-ac50b-8d5fc054d31cff637d30e858ae8ffe2b1d1e8c03.gz
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6fd53c51..706a69bc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -389,6 +389,20 @@ else
AC_MSG_RESULT(no)
fi
+# Check if we are using basic BSD curses - in that case we redefine
+# del_curterm as a no-op, to avoid a double-free
+
+AC_MSG_CHECKING([If we are using BSD curses])
+case $target_os in
+ *bsd*)
+ AC_MSG_RESULT(yes)
+ AC_CHECK_LIB( ncurses, del_curterm, true, [AC_DEFINE([HAVE_BROKEN_DEL_CURTERM],[1],[We are using basic BSD curses, redefine del_curterm to a no-op to avoid a double-free bug])])
+ ;;
+ *)
+ AC_MSG_RESULT(no)
+ ;;
+esac
+
# Tell the world what we know
AC_CONFIG_FILES([Makefile fish.spec doc_src/fish.1 doc_src/Doxyfile etc/fish etc/fish_interactive.fish share/fish seq])
AC_OUTPUT