aboutsummaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar David Adam <zanchey@ucc.gu.uwa.edu.au>2016-05-15 19:36:19 +0000
committerGravatar David Adam <zanchey@ucc.gu.uwa.edu.au>2016-05-18 22:39:20 +0000
commit504b32f61be6bc8a1e08f9c8a75ab0ac1e89681b (patch)
treeba629a7e4d7ae4ac7f01c9f76331357b4a71c3da /configure.ac
parent6a5d89669e1bd2a5c98e61504d73d58ace11c880 (diff)
configure: drop fwprintf test
fwprintf would segfault on DragonFly BSD 1.4.0, released in January 2006. This was fixed by DragonFly BSD 1.4.4, released in April 2006. It seems unlikely that anyone is still running a ten-year-old, unsupported version, and hoping that fish will continue to build. I've checked this in virtual machines. Work on #2999.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac35
1 files changed, 0 insertions, 35 deletions
diff --git a/configure.ac b/configure.ac
index 5907be3e..e50258b0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -405,41 +405,6 @@ AC_LINK_IFELSE(
)
-#
-# If we have a fwprintf in libc, test that it actually works. As of
-# March 2006, it is broken under DragonFly BSD.
-#
-
-if test "$ac_cv_func_fwprintf" = yes; then
-
- AC_MSG_CHECKING([if fwprintf is broken])
- AC_RUN_IFELSE(
- [
- AC_LANG_PROGRAM(
- [
- #include <stdlib.h>
- #include <stdio.h>
- #include <locale.h>
- #include <wchar.h>
- ],
- [
- setlocale( LC_ALL, "" );
- fwprintf( stderr, L"%ls%ls", L"", L"fish:" );
- ]
- )
- ],
- [
- AC_MSG_RESULT(no)
- ],
- [
- AC_MSG_RESULT([yes])
- AC_DEFINE([HAVE_BROKEN_FWPRINTF], [1], [Define to 1 one if the implemented fwprintf is broken])
- ]
- )
-
-fi
-
-
# Check for _nl_msg_cat_cntr symbol
AC_MSG_CHECKING([for _nl_msg_cat_cntr symbol])
AC_TRY_LINK(