aboutsummaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar axel <axel@liljencrantz.se>2006-07-20 00:41:04 +1000
committerGravatar axel <axel@liljencrantz.se>2006-07-20 00:41:04 +1000
commit46c6f7880bebcdb3589e6e8d67a2c192076a540d (patch)
tree5f3f548547fe15cf05951f85bc927af97ea84a39 /configure.ac
parentbef7fff38330872b0e1c5b8a7501c09e4ed1ad1a (diff)
Set value of install path macros like DATADIR from the Makefile, not automatically by Autoconf using AC_DEFINE. That way we get correct expansion of ${prefix} and friends to their install-time value. This fixes a bug reported by James Vega.
darcs-hash:20060719144104-ac50b-05001b151a54bf893ff4c5a82c5f040529e27f57.gz
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 3 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 16efd236..b4eb2d26 100644
--- a/configure.ac
+++ b/configure.ac
@@ -212,17 +212,11 @@ fi
# it can make sure the fish installation directory is in the path
# during startup.
if [[ "$prefix" = NONE ]]; then
- AC_DEFINE_UNQUOTED( [PREFIX], L"/usr/local", [Installation directory])
- AC_SUBST( PREFIX, /usr/local)
export prefix=/usr/local
+ AC_SUBST( prefix, /usr/local)
else
- AC_DEFINE_UNQUOTED( [PREFIX], L"$prefix", [Installation directory])
- AC_SUBST( PREFIX, [$prefix])
+ AC_SUBST( prefix, [$prefix])
fi
-AC_DEFINE_UNQUOTED( SYSCONFDIR, [L"$(eval echo $sysconfdir)"], [System configuration directory] )
-AC_DEFINE_UNQUOTED( DATADIR, [L"$(eval echo $datadir)"], [System configuration directory] )
-AC_SUBST( SYSCONFDIR, ["$(eval echo $sysconfdir)"] )
-AC_SUBST( DATADIR, ["$(eval echo $datadir)"] )
# Set up the directory where the documentation files should be
@@ -237,8 +231,7 @@ fi
# Set up locale directory. This is where the .po files will be
# installed.
-AC_DEFINE_UNQUOTED( [LOCALEDIR], "$(eval echo $datadir)/locale", [Locale directory])
-AC_SUBST( [LOCALEDIR], [$datadir/locale])
+AC_SUBST( [localedir], [$datadir/locale])
# See if Linux procfs is present. This is used to get extra
# information about running processes.