aboutsummaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar axel <axel@liljencrantz.se>2006-02-04 07:29:01 +1000
committerGravatar axel <axel@liljencrantz.se>2006-02-04 07:29:01 +1000
commit3616a23bdd86a870f2173fa84de5080135fd9827 (patch)
treedc19a45f2032af80196e10e91a353a2344a8a6ba /configure.ac
parentf13262d87ea977a023d9f031407aa38c0e576447 (diff)
Add fink and pkgsrc /bin directories to PATH if they exist
darcs-hash:20060203212901-ac50b-94e02eea218c2f40542efd62060a74796cdbe363.gz
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f9801415..6481f5d1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -19,8 +19,18 @@ for i in /usr/pkg /sw; do
AC_MSG_RESULT(no)
fi
+ AC_MSG_CHECKING([for $i/bin command directory])
+ if test -d $i/bin; then
+ AC_MSG_RESULT(yes)
+ optbindirs="$optbindirs $i/bin"
+ else
+ AC_MSG_RESULT(no)
+ fi
+
done
+AC_SUBST( optbindirs, $optbindirs )
+
# If needed, run autoheader automatically
AC_MSG_CHECKING([if autoheader needs to be run])
if test ! -f ./config.h.in -o config.h.in -ot configure.ac; then