aboutsummaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar axel <axel@liljencrantz.se>2006-10-20 01:19:47 +1000
committerGravatar axel <axel@liljencrantz.se>2006-10-20 01:19:47 +1000
commit2d05b1c1b4cf51df30903a24d1d7944aa1b8eeb7 (patch)
tree8f447868c883184e67770e41e02c76321c38c038 /configure.ac
parentea998b03f236be4e8af73474d994af5bbc4b0287 (diff)
Add compiler warnings for some common incorrect usage of functions, such as forgetting to cast null pointers to variadic functions
darcs-hash:20061019151947-ac50b-4043638a7a830fa80fd918f92365f5afe3ff208a.gz
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6af096a0..c0699a29 100644
--- a/configure.ac
+++ b/configure.ac
@@ -92,6 +92,15 @@ AC_SUBST( optbindirs, $optbindirs )
# Tell autoconf to create config.h header
AC_CONFIG_HEADERS(config.h)
+AH_BOTTOM([#if __GNUC__ >= 3
+#define __warn_unused __attribute__ ((warn_unused_result))
+#define __sentinel __attribute__ ((sentinel))
+#else
+#define __warn_unused
+#define __sentinel
+#endif])
+
+
# Set up various programs needed for install
AC_PROG_CC
AC_PROG_CPP