aboutsummaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar axel <axel@liljencrantz.se>2006-10-10 07:24:40 +1000
committerGravatar axel <axel@liljencrantz.se>2006-10-10 07:24:40 +1000
commit194167da32e27e1c0dd6524a537bcfd8944a94c2 (patch)
treea22b9fda77374a7f121c2643ffb23e2a620cde6f /configure.ac
parentdafeac5c4020dd2aede162ed780eb7093afaa413 (diff)
New version of the xdg fix. Unlike the previous version, this one should actually work.
darcs-hash:20061009212440-ac50b-10d1cdd7441335d033171f5b71a8a97f8a1d1dfb.gz
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 3 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index ba21a90d..6af096a0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -225,8 +225,7 @@ if test "$glibc" = yes; then
# fallback.h, in order to keep fish working on non-gnu platforms.
#
- AC_DEFINE( _GNU_SOURCE, 1, [Macro to enable additional prototypes under Glibc])
- AC_DEFINE( _ISOC99_SOURCE, 1, [Macro to enable additional prototypes under Glibc])
+ CFLAGS="$CFLAGS -D_GNU_SOURCE=1 -D_ISO99_SOURCE=1"
else
AC_MSG_RESULT(no)
fi
@@ -291,9 +290,9 @@ fi
AC_ARG_VAR( [docdir], [Documentation direcotry] )
if test -z $docdir; then
- AC_SUBST(docdir, [$datadir/doc/fish] )
+ AC_SUBST(docdir, [$datadir/doc/fish] )
else
- AC_SUBST(docdir, [$docdir])
+ AC_SUBST(docdir, [$docdir])
fi
# Set up locale directory. This is where the .po files will be