aboutsummaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar axel <axel@liljencrantz.se>2006-03-30 07:31:24 +1000
committerGravatar axel <axel@liljencrantz.se>2006-03-30 07:31:24 +1000
commit185d0c3c1c782d0f6e96057b3f23b77844acd68e (patch)
tree33b8825ae07cc5823f44ca86718bed447aae23af /configure.ac
parent3656443b1f5e2cc9b292cb628e95935627bdd666 (diff)
Minor edits in configure.ac
darcs-hash:20060329213124-ac50b-8d25a34d621d698425b54e032238a2fe89d4a031.gz
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 813d2f20..fb91a802 100644
--- a/configure.ac
+++ b/configure.ac
@@ -113,7 +113,7 @@ else
fi
#
-# Test if the compiler accepts the -std=c99 flag. If so, that
+# Test if the compiler accepts the -std=c99 flag. If so, using it
# increases the odds of correct compilation, since we want to use the
# *wprintf functions, which where defined in C99.
#
@@ -165,8 +165,12 @@ if test "$CC" = gcc; then
fi
+#
+# If we are compiling against glibc, set some flags to work around
+# some rather stupid attempts to hide prototypes for *wprintf
+# functions, as well as prototypes of various gnu extensions.
+#
-# Check if we are compiling against glibc
AC_MSG_CHECKING([if we are compiling against glibc])
AC_RUN_IFELSE(
[AC_LANG_PROGRAM([