aboutsummaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar David Adam <zanchey@ucc.gu.uwa.edu.au>2016-05-07 06:29:44 +0800
committerGravatar David Adam <zanchey@ucc.gu.uwa.edu.au>2016-05-18 22:39:20 +0000
commit14187f9e3f3ba14a287803c794b20bd9d913cdab (patch)
tree0c4b8e63a354c74e548120eb275e0f9d43ca42c5 /configure.ac
parent9225b16d1285e620c7c13e3416bdd4099f8ff4b7 (diff)
configure: drop manual checks for __EXTENSIONS__
375bef44432a0fad7ebbd3634a3e950e2d457ec1 includes the appropriate autoconf method of checking for this feature flag. Work on #2999.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 0 insertions, 19 deletions
diff --git a/configure.ac b/configure.ac
index c97b8c51..7dc9a73e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -293,21 +293,6 @@ fi
#
-# Solaris-specific flags go here
-#
-
-AC_MSG_CHECKING([if we are under Solaris])
-case $target_os in
- solaris*)
- AC_DEFINE( __EXTENSIONS__, 1, [Macro to enable additional prototypes under Solaris])
- AC_MSG_RESULT(yes)
- ;;
- *)
- AC_MSG_RESULT(no)
- ;;
-esac
-
-#
# BSD-specific flags go here
#
@@ -413,10 +398,6 @@ AC_DEFINE_UNQUOTED([WCHAR_T_BITS], [$WCHAR_T_BITS], [The size of wchar_t in bits
#
# * This test needs to be run _before_ testing for the presense of any
# prototypes or other language functinality.
-#
-# * This test should be (but does not need to be) run after the
-# conditional definition of __EXTENSIONS__, to avoid redundant tests.
-#
XCXXFLAGS="$CXXFLAGS"