aboutsummaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar David Adam <zanchey@ucc.gu.uwa.edu.au>2014-03-30 13:05:04 +0800
committerGravatar David Adam <zanchey@ucc.gu.uwa.edu.au>2014-03-30 13:11:41 +0800
commit1177daecded5b8dac03097801d4d6111330e1cff (patch)
treed83abecd999b8dd0d98dab984e2c2bd7f0eefd57 /configure.ac
parent42813eeb841ea4a5dbb94e35fb481a163b486d77 (diff)
configure: turn off automatic searches through non-standard directories
configure will no longer check for the existence of extra include, lib and bin directories in /usr/pkg /sw /opt /opt/local /usr/local. The check was not done in a particularly sensible manner and there are now no mandatory dependencies that not shipped in the main system trees on virtually every system in existence. If building with Fink, follow these directions as suggested by the fink project: http://www.finkproject.org/faq/usage-general.php#compile-myself Closes #1185, and closes #1186.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac37
1 files changed, 0 insertions, 37 deletions
diff --git a/configure.ac b/configure.ac
index ccabf62d..23c5b16a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -95,43 +95,6 @@ AC_LANG(C++)
echo "CXXFLAGS: $CXXFLAGS"
#
-# Detect directories which may contain additional headers, libraries
-# and commands. This needs to be done early - before Autoconf starts
-# to mess with CXXFLAGS and all the other environemnt variables.
-#
-# This mostly helps OS X users, since fink usually installs out of
-# tree and doesn't update CXXFLAGS.
-
-for i in /usr/pkg /sw /opt /opt/local /usr/local; do
-
- AC_MSG_CHECKING([for $i/include include directory])
- if test -d $i/include; then
- AC_MSG_RESULT(yes)
- CXXFLAGS="$CXXFLAGS -I$i/include/"
- else
- AC_MSG_RESULT(no)
- fi
-
- AC_MSG_CHECKING([for $i/lib library directory])
- if test -d $i/lib; then
- AC_MSG_RESULT(yes)
- LDFLAGS="$LDFLAGS -L$i/lib/"
- else
- AC_MSG_RESULT(no)
- fi
-
- AC_MSG_CHECKING([for $i/bin command directory])
- if test -d $i/bin; then
- AC_MSG_RESULT(yes)
- optbindirs="$optbindirs $i/bin"
- else
- AC_MSG_RESULT(no)
- fi
-
-done
-
-
-#
# Tell autoconf to create config.h header
#
AC_CONFIG_HEADERS(config.h)