aboutsummaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar David Adam (zanchey) <zanchey@ucc.gu.uwa.edu.au>2013-02-24 04:37:12 +0800
committerGravatar ridiculousfish <corydoras@ridiculousfish.com>2013-03-01 14:54:45 -0800
commit10648cac5b8d6af5b04c6b9a9837959367de7664 (patch)
treecd125ab71a6e57063c37c51f935b9155779c1197 /configure.ac
parent94b1d58cc28800cbc7f00febf499a1d9c9928a21 (diff)
configure: only check for libintl if we want to use gettext (makes --without-gettext actually work)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 37d3e854..059eaac9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -530,7 +530,11 @@ LIBS=$LIBS_COMMON
# Check presense of various header files
#
-AC_CHECK_HEADERS([getopt.h termio.h sys/resource.h term.h ncurses/term.h ncurses.h curses.h stropts.h siginfo.h sys/select.h sys/ioctl.h sys/termios.h libintl.h execinfo.h spawn.h])
+AC_CHECK_HEADERS([getopt.h termio.h sys/resource.h term.h ncurses/term.h ncurses.h curses.h stropts.h siginfo.h sys/select.h sys/ioctl.h sys/termios.h execinfo.h spawn.h])
+
+if test x$local_gettext != xno; then
+ AC_CHECK_HEADERS([libintl.h])
+fi
AC_CHECK_HEADER(
[regex.h],