aboutsummaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Konrad Borowski <x.fix@o2.pl>2014-11-11 12:07:43 +0100
committerGravatar Konrad Borowski <x.fix@o2.pl>2014-11-11 12:07:43 +0100
commit0ea80a319e644c115d93d09f6b23cbaef3a53fe8 (patch)
tree5b8bd4d9cfbd76f2c43640a9d32a48772b694603 /configure.ac
parent38caa0d988c58a8acfee48ec157bd09fb62a4882 (diff)
Move struct stat checks in configure
Tests for POSIX_C_SOURCE value need to be done before any actual checks
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 589d80a1..f0d555f0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -409,12 +409,6 @@ AC_CHECK_HEADER(
)
#
-# Detect nanoseconds fields in struct stat
-#
-AC_CHECK_MEMBERS([struct stat.st_mtimespec.tv_nsec])
-AC_CHECK_MEMBERS([struct stat.st_mtim.tv_nsec])
-
-#
# On some platforms (Solaris 10) adding -std=c99 in turn requires that
# _POSIX_C_SOURCE be defined to 200112L otherwise several
# POSIX-specific, non-ISO-C99 types/prototypes are made unavailable
@@ -528,6 +522,12 @@ if test ! x$local_found_posix_switch = xyes; then
CXXFLAGS="$XCXXFLAGS"
fi
+#
+# Detect nanoseconds fields in struct stat
+#
+AC_CHECK_MEMBERS([struct stat.st_mtimespec.tv_nsec])
+AC_CHECK_MEMBERS([struct stat.st_mtim.tv_nsec])
+
#
# Check for presense of various functions used by fish