aboutsummaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar axel <axel@liljencrantz.se>2006-02-03 10:41:45 +1000
committerGravatar axel <axel@liljencrantz.se>2006-02-03 10:41:45 +1000
commit07c89c71d8d799756725b1b7cf3e03d5ed79826f (patch)
treefffea622e8cf49ec87e975a6c927d6ec25f28b0b /configure.ac
parent19c67db731074a65bef853674180ff3c5f55b460 (diff)
Fix broken test for realpath taking null as a second argument
darcs-hash:20060203004145-ac50b-5357d5f203fa66d5aaef9059e3f03866d2e7f67d.gz
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 1268ec1e..f9801415 100644
--- a/configure.ac
+++ b/configure.ac
@@ -168,8 +168,9 @@ fi
AC_MSG_CHECKING([if realpath accepts null for its second argument])
AC_RUN_IFELSE(
[AC_LANG_PROGRAM([#include <limits.h>
+#include <errno.h>
#include <stdlib.h>],
- [int status; char *res; res = realpath( "foo", 0 ); status = (res && (strlen(res)>3))?0:1; free(res); exit( status );])],
+ [int status; char *res; res = realpath( "somefile", 0 ); status = !(res != 0 || errno == ENOENT); exit( status );])],
[have_realpath_null=yes],
[have_realpath_null=no] )