aboutsummaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar axel <axel@liljencrantz.se>2006-02-03 01:23:56 +1000
committerGravatar axel <axel@liljencrantz.se>2006-02-03 01:23:56 +1000
commit06fd1aa9f8aa2d9705ba942055c76518fb1da1f6 (patch)
tree4a6d3e47b2b282d3b376ae31dbc02fae0a8f145f /configure.ac
parent5942a6d6c193f6d985d9f4eaada7c8113a40d1c0 (diff)
Make stack traces print absolute filenames
darcs-hash:20060202152356-ac50b-9e6ab31c03d5f49824ccca7eee3b8e62d66b0009.gz
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 19 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 32eba6af..d104c7da 100644
--- a/configure.ac
+++ b/configure.ac
@@ -18,8 +18,9 @@ for i in /usr/pkg /sw; do
else
AC_MSG_RESULT(no)
fi
+
done
-
+
# If needed, run autoheader automatically
AC_MSG_CHECKING([if autoheader needs to be run])
if test ! -f ./config.h.in -o config.h.in -ot configure.ac; then
@@ -163,6 +164,23 @@ else
AC_MSG_RESULT(no)
fi
+# Check if realpath accepts null for its second argument
+AC_MSG_CHECKING([if realpath accepts null for its second argument])
+AC_RUN_IFELSE(
+ [AC_LANG_PROGRAM([#include <limits.h>
+#include <stdlib.h>],
+ [int status; char *res; res = realpath( "foo", 0 ); status = (res && (strlen(res)>3))?0:1; free(res); exit( status );])],
+ [have_realpath_null=yes],
+ [have_realpath_null=no] )
+
+if test "$have_realpath_null" = yes; then
+ AC_MSG_RESULT(yes)
+ AC_DEFINE([HAVE_REALPATH_NULL], [1],
+ [Define to 1 if realpath accepts null for its second argument.])
+else
+ AC_MSG_RESULT(no)
+fi
+
# Check for libraries
AC_CHECK_LIB(socket, connect)