aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0cdddec..c2bf56d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -47,10 +47,13 @@ set(
enable_testing()
+# These are ordered by a topological sort on DEPENDS attributes. This is
+# required because CMake fails the build if you have a DEPENDS on a target that
+# does not exist yet.
include(external/FirebaseCore)
include(external/googletest)
include(external/leveldb)
-include(external/grpc)
include(external/protobuf)
include(external/nanopb)
+include(external/grpc)
include(external/firestore)