aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gil <mcg@google.com>2018-06-26 15:05:28 -0700
committerGravatar GitHub <noreply@github.com>2018-06-26 15:05:28 -0700
commit3722deff12ec2e79c479ceae3a829752f92bb710 (patch)
treeb9d779ffe5ead20ffebf988c7f115b35fde428eb /CMakeLists.txt
parentd03050653ff84e624def93aa512ef35907f5792a (diff)
Install protobuf during CMake build (#1460)
* Install protobuf * Use the built-in FindProtobuf.cmake * Add additional build configuration flags * Preserve generator configuration in the protobuf sub-build Without this, the build fails on Win64 because the default configuration builds a Win32 libprotobuf and the Win64 build rejects it. * Wire the installed protobuf into the gRPC build. * Install nanopb
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0cdddec..c2bf56d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -47,10 +47,13 @@ set(
enable_testing()
+# These are ordered by a topological sort on DEPENDS attributes. This is
+# required because CMake fails the build if you have a DEPENDS on a target that
+# does not exist yet.
include(external/FirebaseCore)
include(external/googletest)
include(external/leveldb)
-include(external/grpc)
include(external/protobuf)
include(external/nanopb)
+include(external/grpc)
include(external/firestore)