aboutsummaryrefslogtreecommitdiffhomepage
path: root/Firestore/core/src/firebase/firestore/remote/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gil <mcg@google.com>2018-01-17 10:24:27 -0800
committerGravatar GitHub <noreply@github.com>2018-01-17 10:24:27 -0800
commit6a3379db62ccbce7fc9a859032955614e78e68bb (patch)
treee50af3689dfcb0a55478bc92272821bbbc6a8f81 /Firestore/core/src/firebase/firestore/remote/CMakeLists.txt
parentc3664973a94a2c715b9c57583f5953483caf2cce (diff)
Add a cc_library to the CMake build (#670)
* Rewrite cc_test to take named arguments Cut down on build file verbosity by having cc_test take SOURCES and DEPENDS. The separate invocation of target_link_libraries is no longer necessary. * Add a cc_library rule to parallel cc_test This cuts down on build file verbosity. * Automatically add OBJC_FLAGS to cc_libraries if applicable * Exclude platform-specific libraries from 'all' This is makes it possible to declare this kind of library unconditionally. Usage within a test or as a dependency will actually trigger building. * Restore secure_random_test.cc; clean-up comments
Diffstat (limited to 'Firestore/core/src/firebase/firestore/remote/CMakeLists.txt')
-rw-r--r--Firestore/core/src/firebase/firestore/remote/CMakeLists.txt13
1 files changed, 6 insertions, 7 deletions
diff --git a/Firestore/core/src/firebase/firestore/remote/CMakeLists.txt b/Firestore/core/src/firebase/firestore/remote/CMakeLists.txt
index 74ad80b..43320ce 100644
--- a/Firestore/core/src/firebase/firestore/remote/CMakeLists.txt
+++ b/Firestore/core/src/firebase/firestore/remote/CMakeLists.txt
@@ -12,12 +12,11 @@
# See the License for the specific language governing permissions and
# limitations under the License.
-add_library(
+cc_library(
firebase_firestore_remote
- datastore.h
- datastore.cc
-)
-target_link_libraries(
- firebase_firestore_remote
- grpc::grpc
+ SOURCES
+ datastore.h
+ datastore.cc
+ DEPENDS
+ grpc::grpc
)