aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gil <mcg@google.com>2018-07-10 07:57:54 -0700
committerGravatar GitHub <noreply@github.com>2018-07-10 07:57:54 -0700
commit50cbfab391f50efd2f2270f24c3ca2e48e039510 (patch)
treeeebcba9137567c219b1bd5e939d84057e0e66a2e /CMakeLists.txt
parent954e4d5df13b14aee9c1112db67a23729d12acfd (diff)
Reorganize cmake dependencies (#1508)
* Add cmake dependencies where required ... instead of relying on a topological sort in the top-level CMakeLists.txt. * Add early exits to external project builds
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 1 insertions, 12 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 10d8ce2..b5f6970 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -47,16 +47,5 @@ set(
enable_testing()
-# These are ordered by a topological sort on DEPENDS attributes. This is
-# required because CMake fails the build if you have a DEPENDS on a target that
-# does not exist yet.
-include(external/GoogleUtilities)
-include(external/FirebaseCore)
-include(external/googletest)
-include(external/zlib)
-include(external/leveldb)
-include(external/protobuf)
-include(external/nanopb)
-include(external/c-ares)
-include(external/grpc)
+include(ExternalProject)
include(external/firestore)