aboutsummaryrefslogtreecommitdiffhomepage
path: root/unsupported/test/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gael Guennebaud <g.gael@free.fr>2018-07-23 19:38:55 +0000
committerGravatar Gael Guennebaud <g.gael@free.fr>2018-07-23 19:38:55 +0000
commit2c2de9da7de97fc31e1ab73a254a70a28fa023f0 (patch)
tree7dd18dcc5cc3fb4afd211586d61efd79f5938f11 /unsupported/test/CMakeLists.txt
parent4ca3e48f42adab8f907c18c64107dd23d432ccdc (diff)
parent02eaaacbc5b4f51718e9a82b7ede57659bdb514a (diff)
Merged in glchaves/eigen (pull request PR-433)
Move cxx11_tensor_uint128 test under an EIGEN_TEST_CXX11 guarded block
Diffstat (limited to 'unsupported/test/CMakeLists.txt')
-rw-r--r--unsupported/test/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/unsupported/test/CMakeLists.txt b/unsupported/test/CMakeLists.txt
index 0fc864eca..55b86a32f 100644
--- a/unsupported/test/CMakeLists.txt
+++ b/unsupported/test/CMakeLists.txt
@@ -141,10 +141,6 @@ ei_add_test(cxx11_tensor_sugar)
ei_add_test(cxx11_tensor_roundings)
ei_add_test(cxx11_tensor_layout_swap)
ei_add_test(cxx11_tensor_io)
-if("${CMAKE_SIZEOF_VOID_P}" EQUAL "8")
- # This test requires __uint128_t which is only available on 64bit systems
- ei_add_test(cxx11_tensor_uint128)
-endif()
endif()
if(EIGEN_TEST_CXX11)
@@ -226,6 +222,10 @@ if(EIGEN_TEST_CXX11)
ei_add_test(cxx11_tensor_scan)
ei_add_test(cxx11_tensor_trace)
ei_add_test(cxx11_tensor_move)
+if("${CMAKE_SIZEOF_VOID_P}" EQUAL "8" AND NOT CMAKE_CXX_COMPILER_ID STREQUAL "MSVC")
+ # This test requires __uint128_t which is only available on 64bit systems
+ ei_add_test(cxx11_tensor_uint128)
+endif()
endif()