aboutsummaryrefslogtreecommitdiffhomepage
path: root/unsupported/test/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gustavo Lima Chaves <gustavo.lima.chaves@intel.com>2018-07-20 16:08:40 -0700
committerGravatar Gustavo Lima Chaves <gustavo.lima.chaves@intel.com>2018-07-20 16:08:40 -0700
commit02eaaacbc5b4f51718e9a82b7ede57659bdb514a (patch)
tree8c9c561cc6bc827332a8b2cc80861885f1d36d4c /unsupported/test/CMakeLists.txt
parentde70671937827dd61a63d2432e0bea4ca7b00300 (diff)
Move cxx11_tensor_uint128 test under an EIGEN_TEST_CXX11 guarded
block Builds configured without the -DEIGEN_TEST_CXX11=ON flag would fail right away without this, as this test seems to rely on those language features. The skip under compilation with MSVC was kept.
Diffstat (limited to 'unsupported/test/CMakeLists.txt')
-rw-r--r--unsupported/test/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/unsupported/test/CMakeLists.txt b/unsupported/test/CMakeLists.txt
index 0fc864eca..55b86a32f 100644
--- a/unsupported/test/CMakeLists.txt
+++ b/unsupported/test/CMakeLists.txt
@@ -141,10 +141,6 @@ ei_add_test(cxx11_tensor_sugar)
ei_add_test(cxx11_tensor_roundings)
ei_add_test(cxx11_tensor_layout_swap)
ei_add_test(cxx11_tensor_io)
-if("${CMAKE_SIZEOF_VOID_P}" EQUAL "8")
- # This test requires __uint128_t which is only available on 64bit systems
- ei_add_test(cxx11_tensor_uint128)
-endif()
endif()
if(EIGEN_TEST_CXX11)
@@ -226,6 +222,10 @@ if(EIGEN_TEST_CXX11)
ei_add_test(cxx11_tensor_scan)
ei_add_test(cxx11_tensor_trace)
ei_add_test(cxx11_tensor_move)
+if("${CMAKE_SIZEOF_VOID_P}" EQUAL "8" AND NOT CMAKE_CXX_COMPILER_ID STREQUAL "MSVC")
+ # This test requires __uint128_t which is only available on 64bit systems
+ ei_add_test(cxx11_tensor_uint128)
+endif()
endif()