aboutsummaryrefslogtreecommitdiffhomepage
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gael Guennebaud <g.gael@free.fr>2008-08-23 15:14:20 +0000
committerGravatar Gael Guennebaud <g.gael@free.fr>2008-08-23 15:14:20 +0000
commit2120fed849e1d00724694a2c8a041ec5561c750b (patch)
tree984bb801927df2aa12cf866fc76465466bd40eb6 /test/CMakeLists.txt
parent312013a08911816e287425d598e55e5d356e0ac5 (diff)
* bug fixes in: Dot, generalized eigen problem, singular matrix detetection in Cholesky
* fix all numerical instabilies in the unit tests, now all tests can be run 2000 times with almost zero failures.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 8d217d421..680a8e65f 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -1,5 +1,9 @@
IF(BUILD_TESTS)
+find_package(GSL)
+if(GSL_FOUND)
+ add_definitions("-DHAS_GSL")
+endif(GSL_FOUND)
IF(CMAKE_COMPILER_IS_GNUCXX)
IF(CMAKE_SYSTEM_NAME MATCHES Linux)
@@ -69,6 +73,10 @@ MACRO(EI_ADD_TEST testname)
target_link_libraries(${targetname} Eigen2)
ENDIF(TEST_LIB)
+ if(GSL_FOUND)
+ target_link_libraries(${targetname} ${GSL_LIBRARIES})
+ endif(GSL_FOUND)
+
IF(WIN32)
ADD_TEST(${testname} "${targetname}")
ELSE(WIN32)