aboutsummaryrefslogtreecommitdiffhomepage
path: root/scripts/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Benoit Jacob <jacob.benoit.1@gmail.com>2009-12-30 15:07:05 -0500
committerGravatar Benoit Jacob <jacob.benoit.1@gmail.com>2009-12-30 15:07:05 -0500
commit2038f9cc8d03b02e2eb4173a3e4726f3318e74be (patch)
tree41aab32340a41688ca01ea17fb3d22e1de799c28 /scripts/CMakeLists.txt
parent233540e58af2b2ae8129174a957a68d1eea71bf2 (diff)
* The 'check' and 'buildtests' scripts no longer take a jobs parameter.
Instead, they honor the EIGEN_JOBS environment variable if defined. * The syntax ${BLABLA} in bash scripts was conflicting with CMake configured file syntax. Resolved by using the @ONLY option and the @BLABLA@ syntax.
Diffstat (limited to 'scripts/CMakeLists.txt')
-rw-r--r--scripts/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/scripts/CMakeLists.txt b/scripts/CMakeLists.txt
index acf3bb6e9..7e2c9ca7a 100644
--- a/scripts/CMakeLists.txt
+++ b/scripts/CMakeLists.txt
@@ -1,6 +1,6 @@
get_property(EIGEN_TESTS_LIST GLOBAL PROPERTY EIGEN_TESTS_LIST)
-configure_file(buildtests.in ${CMAKE_BINARY_DIR}/buildtests)
+configure_file(buildtests.in ${CMAKE_BINARY_DIR}/buildtests @ONLY)
-configure_file(check.in ${CMAKE_BINARY_DIR}/check)
-configure_file(debug.in ${CMAKE_BINARY_DIR}/debug)
-configure_file(release.in ${CMAKE_BINARY_DIR}/release)
+configure_file(check.in ${CMAKE_BINARY_DIR}/check COPYONLY)
+configure_file(debug.in ${CMAKE_BINARY_DIR}/debug COPYONLY)
+configure_file(release.in ${CMAKE_BINARY_DIR}/release COPYONLY)