aboutsummaryrefslogtreecommitdiffhomepage
path: root/blas/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Benoit Steiner <benoit.steiner.goog@gmail.com>2015-02-06 05:25:03 -0800
committerGravatar Benoit Steiner <benoit.steiner.goog@gmail.com>2015-02-06 05:25:03 -0800
commitc739102ef9a52fcb194dcc77f785aa55879987e4 (patch)
tree22d19d1df4cb20baea532fa1ce13208329ff53e3 /blas/CMakeLists.txt
parent2559fa9b0f20ea138cfb019d441ad1757221568d (diff)
parenta8f2c6eec788c5cccc6beb9b5837544ea98a7154 (diff)
Pulled the latest changes from the trunk
Diffstat (limited to 'blas/CMakeLists.txt')
-rw-r--r--blas/CMakeLists.txt27
1 files changed, 11 insertions, 16 deletions
diff --git a/blas/CMakeLists.txt b/blas/CMakeLists.txt
index a9bc05137..d0efb4188 100644
--- a/blas/CMakeLists.txt
+++ b/blas/CMakeLists.txt
@@ -14,23 +14,18 @@ endif()
add_custom_target(blas)
-set(EigenBlas_SRCS single.cpp double.cpp complex_single.cpp complex_double.cpp xerbla.cpp)
-
-if(EIGEN_Fortran_COMPILER_WORKS)
-
-set(EigenBlas_SRCS ${EigenBlas_SRCS}
- complexdots.f
- srotm.f srotmg.f drotm.f drotmg.f
- lsame.f dspmv.f ssbmv.f
- chbmv.f sspmv.f
- zhbmv.f chpmv.f dsbmv.f
- zhpmv.f
- dtbmv.f stbmv.f ctbmv.f ztbmv.f
-)
+set(EigenBlas_SRCS single.cpp double.cpp complex_single.cpp complex_double.cpp xerbla.cpp
+ f2c/srotm.c f2c/srotmg.c f2c/drotm.c f2c/drotmg.c
+ f2c/lsame.c f2c/dspmv.c f2c/ssbmv.c f2c/chbmv.c
+ f2c/sspmv.c f2c/zhbmv.c f2c/chpmv.c f2c/dsbmv.c
+ f2c/zhpmv.c f2c/dtbmv.c f2c/stbmv.c f2c/ctbmv.c
+ f2c/ztbmv.c f2c/d_cnjg.c f2c/r_cnjg.c
+ )
+
+if (EIGEN_Fortran_COMPILER_WORKS)
+ set(EigenBlas_SRCS ${EigenBlas_SRCS} fortran/complexdots.f)
else()
-
-message(WARNING " No fortran compiler has been detected, the blas build will be incomplete.")
-
+ set(EigenBlas_SRCS ${EigenBlas_SRCS} f2c/complexdots.c)
endif()
add_library(eigen_blas_static ${EigenBlas_SRCS})