aboutsummaryrefslogtreecommitdiffhomepage
path: root/blas/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gael Guennebaud <g.gael@free.fr>2009-09-25 13:08:39 +0200
committerGravatar Gael Guennebaud <g.gael@free.fr>2009-09-25 13:08:39 +0200
commit04dc63776a63e5d0ec0237706cb440152d57769e (patch)
tree00f0890a8d4bb6617262adb5cfb90c0307fa9c57 /blas/CMakeLists.txt
parentbdf603caecc72f8250f212c497d6cf2b42e1c054 (diff)
add a wip blas library built on top of Eigen. TODO:
- write extentive unit tests (maybe this already exist in other projects) - the level2 functions still have to be implemented
Diffstat (limited to 'blas/CMakeLists.txt')
-rw-r--r--blas/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/blas/CMakeLists.txt b/blas/CMakeLists.txt
new file mode 100644
index 000000000..477693bad
--- /dev/null
+++ b/blas/CMakeLists.txt
@@ -0,0 +1,10 @@
+
+set(EigenBlas_SRCS single.cpp double.cpp complex_single.cpp complex_double.cpp)
+
+add_library(eigen_blas SHARED ${EigenBlas_SRCS})
+
+install(TARGETS eigen_blas
+ RUNTIME DESTINATION bin
+ LIBRARY DESTINATION lib
+ ARCHIVE DESTINATION lib)
+