aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Desire NUENTSA <desire.nuentsa_wakam@inria.fr>2012-03-29 14:32:54 +0200
committerGravatar Desire NUENTSA <desire.nuentsa_wakam@inria.fr>2012-03-29 14:32:54 +0200
commitf804a319c81cb1629abb9bdc97dd74a2d2dec3d7 (patch)
tree5d59101e9f756ed2cc02ae6047dcaaf8a67dbfe4 /CMakeLists.txt
parentada9e791450618d1d608db11fcdd97adde824cbe (diff)
modify the unit tests of sparse linear solvers to enable tests on real matrices, from MatrixMarket for instance
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d39976aee..bc77bcb2e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -338,6 +338,13 @@ if(EIGEN_BUILD_BTL)
add_subdirectory(bench/btl EXCLUDE_FROM_ALL)
endif(EIGEN_BUILD_BTL)
+if(TEST_REAL_CASES)
+ if(NOT WIN32)
+ add_subdirectory(bench/spbench EXCLUDE_FROM_ALL)
+ set(ENV(EIGEN_MATRIX_DIR) ${TEST_REAL_CASES})
+ endif(NOT WIN32)
+endif(TEST_REAL_CASES)
+
ei_testing_print_summary()
message(STATUS "")